using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d)(?!\2{3})){16}";
string input = @"5123456789123456
6123456789123456
4123356789123456
5133336789123456
1234567890134443";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}