re = /((\d)(?!\2{3})){16}/
str = '5123456789123456
6123456789123456
4123356789123456
5133336789123456
1234567890134443'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end