const regex = /((\d)(?!\2{3})){16}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d)(?!\\2{3})){16}', 'g')
const str = `5123456789123456
6123456789123456
4123356789123456
5133336789123456
1234567890134443`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}