import re
regex = re.compile(r"((\d)(?!\2{3})){16}")
test_str = ("5123456789123456\n"
"6123456789123456\n"
"4123356789123456\n"
"5133336789123456\n"
"1234567890134443")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")