$re = '/((\d)(?!\2{3})){16}/';
$str = '5123456789123456
6123456789123456
4123356789123456
5133336789123456
1234567890134443';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);