using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\h*\K[^\s]+(?=.*$[\s\S]*<<)";
string input = @">>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<BROWSING>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<OTHER>>
www.google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}