use strict;
my $str = '>>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<BROWSING>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<OTHER>>
www.google.com';
my $regex = qr/^\h*\K[^\s]+(?=.*$[\s\S]*<<)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}