import Foundation
let pattern = #"^\h*\K[^\s]+(?=.*$[\s\S]*<<)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
>>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<BROWSING>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<OTHER>>
www.google.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)