const regex = /^\h*\K[^\s]+(?=.*$[\s\S]*<<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h*\\K[^\\s]+(?=.*$[\\s\\S]*<<)', 'gm')
const str = `>>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<BROWSING>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<OTHER>>
www.google.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}