re = /^\h*\K[^\s]+(?=.*$[\s\S]*<<)/m
str = '>>
https://sharefile.com/Authentication/Login some stuff
https://fox1.functionfox.com/timefox/main.asp
<<BROWSING>>
behance.net
http://www.twitter.com
http://theoldreader.com
http://www.reddit.com
https://mail.google.com
https://analytics.google.com/analytics/web/#home
http://www.youtube.com
<<OTHER>>
www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end