using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?(.*)";
string input = @"http://www.example.com?go1=test1
http://www.example.com?go2=test2
http://www.example.com?go1=test1&go3=test3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}