package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?(.*)`)
var str = `http://www.example.com?go1=test1
http://www.example.com?go2=test2
http://www.example.com?go1=test1&go3=test3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}