$re = '/\?(.*)/';
$str = 'http://www.example.com?go1=test1
http://www.example.com?go2=test2
http://www.example.com?go1=test1&go3=test3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);