// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\?(.*)").unwrap();
let string = "http://www.example.com?go1=test1
http://www.example.com?go2=test2
http://www.example.com?go1=test1&go3=test3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}