# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(foo\=[^\&]*)|(foo(?=\&))|(?:\&(foo(?!.)))/match/gi;t' <<< "foo?foo=bar&foo&foofoo
foo?foo=bar&foo&foo"