use strict;
my $str = 'foo?foo=bar&foo&foofoo
foo?foo=bar&foo&foo';
my $regex = qr/(foo\=[^\&]*)|(foo(?=\&))|(?:\&(foo(?!.)))/ip;
my $subst = 'match';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";