const regex = /(foo\=[^\&]*)|(foo(?=\&))|(?:\&(foo(?!.)))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(foo\\=[^\\&]*)|(foo(?=\\&))|(?:\\&(foo(?!.)))', 'gi')
const str = `foo?foo=bar&foo&foofoo
foo?foo=bar&foo&foo`;
const subst = `match`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);