import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(foo\\=[^\\&]*)|(foo(?=\\&))|(?:\\&(foo(?!.)))";
final String string = "foo?foo=bar&foo&foofoo\n"
+ "foo?foo=bar&foo&foo";
final String subst = "match";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}