re = /(foo\=[^\&]*)|(foo(?=\&))|(?:\&(foo(?!.)))/i
str = 'foo?foo=bar&foo&foofoo
foo?foo=bar&foo&foo'
subst = 'match'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result