#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?s).*someArray\[\].*?=.*?\[|\G[^"\]]+)"(.*?)""
Local $sString = "anythingHere "Can you see me?"" & @CRLF & _
"...random code" & @CRLF & _
"someArray[] = ["Come and"," & @CRLF & _
" "get me,"," & @CRLF & _
" "or fail"," & @CRLF & _
" "trying!"," & @CRLF & _
" "Yours truly"]" & @CRLF & _
"random code..." & @CRLF & _
""some string""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")