$re = '/(?:(?s).*someArray\[\].*?=.*?\[|\G[^"\]]+)"(.*?)"/';
$str = 'anythingHere "Can you see me?"
...random code
someArray[] = ["Come and",
"get me,",
"or fail",
"trying!",
"Yours truly"]
random code...
"some string"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);