using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?s).*someArray\[\].*?=.*?\[|\G[^""\]]+)""(.*?)""";
string input = @"anythingHere ""Can you see me?""
...random code
someArray[] = [""Come and"",
""get me,"",
""or fail"",
""trying!"",
""Yours truly""]
random code...
""some string""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}