import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?s).*someArray\\[\\].*?=.*?\\[|\\G[^\"\\]]+)\"(.*?)\"";
final String string = "anythingHere \"Can you see me?\"\n"
+ "...random code\n"
+ "someArray[] = [\"Come and\",\n"
+ " \"get me,\",\n"
+ " \"or fail\",\n"
+ " \"trying!\",\n"
+ " \"Yours truly\"]\n"
+ "random code...\n"
+ "\"some string\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}