re = /(?:(?s).*someArray\[\].*?=.*?\[|\G[^"\]]+)"(.*?)"/
str = 'anythingHere "Can you see me?"
...random code
someArray[] = ["Come and",
"get me,",
"or fail",
"trying!",
"Yours truly"]
random code...
"some string"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end