using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?://(?:\w+(?:-\w+)*\.)*domain-name\.com(?=$|[/?#])";
string input = @"https://subdomain.domain-name.com
http://subdomain.domain-name.com
https://domain-name.com
https://subdomain.domain-name.com/some-url
https://domain-name.com/some-url
https://sub-subdomain.subdomain.domain-name.com
https://domain-name.com?params=values
https://domain-name.com#fragment
https://subdomain.not-domain-name.com
https://not-domain-name.com
http://subdomain.not-domain-name.com/some-url
../local.links";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}