const regex = new RegExp('^https?://(?:\\w+(?:-\\w+)*\\.)*domain-name\\.com(?=$|[/?#])', 'gm')
const str = `https://subdomain.domain-name.com
http://subdomain.domain-name.com
https://domain-name.com
https://subdomain.domain-name.com/some-url
https://domain-name.com/some-url
https://sub-subdomain.subdomain.domain-name.com
https://domain-name.com?params=values
https://domain-name.com#fragment
https://subdomain.not-domain-name.com
https://not-domain-name.com
http://subdomain.not-domain-name.com/some-url
../local.links`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}