import Foundation
let pattern = ##"^https?://(?:\w+(?:-\w+)*\.)*domain-name\.com(?=$|[/?#])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://subdomain.domain-name.com
http://subdomain.domain-name.com
https://domain-name.com
https://subdomain.domain-name.com/some-url
https://domain-name.com/some-url
https://sub-subdomain.subdomain.domain-name.com
https://domain-name.com?params=values
https://domain-name.com#fragment
https://subdomain.not-domain-name.com
https://not-domain-name.com
http://subdomain.not-domain-name.com/some-url
../local.links
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)