import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?://(?:\\w+(?:-\\w+)*\\.)*domain-name\\.com(?=$|[/?#])";
final String string = "https://subdomain.domain-name.com\n"
+ "http://subdomain.domain-name.com\n"
+ "https://domain-name.com\n"
+ "https://subdomain.domain-name.com/some-url\n"
+ "https://domain-name.com/some-url\n"
+ "https://sub-subdomain.subdomain.domain-name.com\n"
+ "https://domain-name.com?params=values\n"
+ "https://domain-name.com#fragment\n\n"
+ "https://subdomain.not-domain-name.com\n"
+ "https://not-domain-name.com\n"
+ "http://subdomain.not-domain-name.com/some-url\n\n"
+ "../local.links";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}