$re = '@^https?://(?:\w+(?:-\w+)*\.)*domain-name\.com(?=$|[/?#])@m';
$str = 'https://subdomain.domain-name.com
http://subdomain.domain-name.com
https://domain-name.com
https://subdomain.domain-name.com/some-url
https://domain-name.com/some-url
https://sub-subdomain.subdomain.domain-name.com
https://domain-name.com?params=values
https://domain-name.com#fragment
https://subdomain.not-domain-name.com
https://not-domain-name.com
http://subdomain.not-domain-name.com/some-url
../local.links';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);