using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[😁-🙏]|[✂-➰]|[🚀-🛀]|[Ⓜ-🉑]|[©-🗿]|[😀-😶]|[🚁-🛅]|[🌍-🕧]|<:.+:\d+>";
string input = @"Test test 👍
Why is no worky? 😞 :waffle:
🔥 <:bungie_portrait:1316513270202368050> 👋";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}