$re = '/[😁-🙏]|[✂-➰]|[🚀-🛀]|[Ⓜ-🉑]|[©-🗿]|[😀-😶]|[🚁-🛅]|[🌍-🕧]|<:.+:\d+>/u';
$str = 'Test test 👍
Why is no worky? 😞 :waffle:
🔥 <:bungie_portrait:1316513270202368050> 👋';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);