re = /[😁-🙏]|[✂-➰]|[🚀-🛀]|[Ⓜ-🉑]|[©-🗿]|[😀-😶]|[🚁-🛅]|[🌍-🕧]|<:.+:\d+>/
str = 'Test test 👍
Why is no worky? 😞 :waffle:
🔥 <:bungie_portrait:1316513270202368050> 👋'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end