import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[😁-🙏]|[✂-➰]|[🚀-🛀]|[Ⓜ-🉑]|[©-🗿]|[😀-😶]|[🚁-🛅]|[🌍-🕧]|<:.+:\\d+>";
final String string = "Test test 👍\n"
+ "Why is no worky? 😞 :waffle: \n\n"
+ "🔥 <:bungie_portrait:1316513270202368050> 👋";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}