package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[😁-🙏]|[✂-➰]|[🚀-🛀]|[Ⓜ-🉑]|[©-🗿]|[😀-😶]|[🚁-🛅]|[🌍-🕧]|<:.+:\d+>`)
var str = `Test test 👍
Why is no worky? 😞 :waffle:
🔥 <:bungie_portrait:1316513270202368050> 👋`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}