using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"goTo_(\d+)_(\d+)_(\d+)";
string input = @"param-out goTo goTo_1_1_1 goTo_2_1_2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}