const regex = /goTo_(\d+)_(\d+)_(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('goTo_(\\d+)_(\\d+)_(\\d+)', 'g')
const str = `param-out goTo goTo_1_1_1 goTo_2_1_2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}