package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`goTo_(\d+)_(\d+)_(\d+)`)
var str = `param-out goTo goTo_1_1_1 goTo_2_1_2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}