$re = '/goTo_(\d+)_(\d+)_(\d+)/';
$str = 'param-out goTo goTo_1_1_1 goTo_2_1_2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);