using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(transaction\("".*?)(_.*"")";
string input = @"lr_end_transaction(""001_0010_123-A1-a_text-or-numbers"",LR_AUTO);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}