const regex = /(transaction\(".*?)(_.*")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(transaction\\(".*?)(_.*")', 'gm')
const str = `lr_end_transaction("001_0010_123-A1-a_text-or-numbers",LR_AUTO);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}