package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(transaction\(".*?)(_.*")`)
var str = `lr_end_transaction("001_0010_123-A1-a_text-or-numbers",LR_AUTO);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}