$re = '/(transaction\(".*?)(_.*")/m';
$str = 'lr_end_transaction("001_0010_123-A1-a_text-or-numbers",LR_AUTO);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);