// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(transaction\(".*?)(_.*")"#).unwrap();
let string = "lr_end_transaction(\"001_0010_123-A1-a_text-or-numbers\",LR_AUTO);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}