using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w[-._\w]*\w@\w[-._\w]*\w\.[A-Za-z]{2,3})";
string input = @"abc@live.co.in";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}