import Foundation
let pattern = #"(\w[-._\w]*\w@\w[-._\w]*\w\.[A-Za-z]{2,3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abc@live.co.in"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}