$re = '/(\w[-._\w]*\w@\w[-._\w]*\w\.[A-Za-z]{2,3})/';
$str = 'abc@live.co.in';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);