package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w[-._\w]*\w@\w[-._\w]*\w\.[A-Za-z]{2,3})`)
var str = `abc@live.co.in`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}