const regex = /(\w[-._\w]*\w@\w[-._\w]*\w\.[A-Za-z]{2,3})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w[-._\\w]*\\w@\\w[-._\\w]*\\w\\.[A-Za-z]{2,3})', '')
const str = `abc@live.co.in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}