import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*: )(.*)";
final String string = "EN Normen: EN Normen\n"
+ "Schuhtyp: FUS Schuhtyp\n"
+ "Schuhform: FUS Schuhform\n"
+ "Verschlussart: FUS Verschlussart\n"
+ "Verschlusselement: FUS Verschluss\n"
+ "Größe: Größe Von - Größe bis\n"
+ "Größenbereich: Größenbereich\n"
+ "Passform: v FUS Passform\n"
+ "Schuhweite: v FUS Schuhweite\n"
+ "Schafthöhe: v FUS Schafthöhe CM\n"
+ "Farbe: v Farbe list\n"
+ "Farbcode: v Farbcode\n"
+ "Obermaterial: FUS Obermaterial\n"
+ "Obermaterial sonstige: FUS Obermaterial Sonstige\n"
+ "Lederausprägung: FUS Lederausprägung\n"
+ "Innenfutter: FUS Innenfutter\n"
+ "Innenfutter sonstige: FUS Innenfutter Sonstige\n"
+ "Blattfutter: FUS Blattfutter\n"
+ "Quartierfutter: FUS Quartierfutter\n"
+ "Fersenfutter: FUS Fersenfutter\n"
+ "Schaftrand: FUS Schaftrand\n"
+ "Lasche: FUS Lasche\n"
+ "Lasche sonstige: FUS Lasche Sonstige\n"
+ "Zehenschutzkappe: FUS Zehenschutzkappe\n"
+ "Verstärkungen: FUS Pikto2\n"
+ "Schuhkappe: FUS Schuhkappe\n"
+ "Einlegesohle: FUS Einlegesohle\n"
+ "Einlegesohle sonstige: FUS Einlegesohle Sonstige\n"
+ "Zwischensohle: FUS Zwischensohle\n"
+ "Zwischensohle sonstige: FUS Zwischensohle Sonstige\n"
+ "Brandsohle: FUS Brandsohle\n"
+ "Laufsohle: FUS Laufsohle\n"
+ "Ausstattung: Ausstattung\n"
+ "Geeigneter Untergrund: FUS Geeigneter Untergrund\n"
+ "Sicherheitsschuhklasse: FUS Sicherheitsklassen\n"
+ "Schutzschuh Klasse: FUS Schutzklasse\n"
+ "Berufsschuh Klasse: FUS Berufsschuhklasse";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}