import Foundation
let pattern = #"(.*: )(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
EN Normen: EN Normen
Schuhtyp: FUS Schuhtyp
Schuhform: FUS Schuhform
Verschlussart: FUS Verschlussart
Verschlusselement: FUS Verschluss
Größe: Größe Von - Größe bis
Größenbereich: Größenbereich
Passform: v FUS Passform
Schuhweite: v FUS Schuhweite
Schafthöhe: v FUS Schafthöhe CM
Farbe: v Farbe list
Farbcode: v Farbcode
Obermaterial: FUS Obermaterial
Obermaterial sonstige: FUS Obermaterial Sonstige
Lederausprägung: FUS Lederausprägung
Innenfutter: FUS Innenfutter
Innenfutter sonstige: FUS Innenfutter Sonstige
Blattfutter: FUS Blattfutter
Quartierfutter: FUS Quartierfutter
Fersenfutter: FUS Fersenfutter
Schaftrand: FUS Schaftrand
Lasche: FUS Lasche
Lasche sonstige: FUS Lasche Sonstige
Zehenschutzkappe: FUS Zehenschutzkappe
Verstärkungen: FUS Pikto2
Schuhkappe: FUS Schuhkappe
Einlegesohle: FUS Einlegesohle
Einlegesohle sonstige: FUS Einlegesohle Sonstige
Zwischensohle: FUS Zwischensohle
Zwischensohle sonstige: FUS Zwischensohle Sonstige
Brandsohle: FUS Brandsohle
Laufsohle: FUS Laufsohle
Ausstattung: Ausstattung
Geeigneter Untergrund: FUS Geeigneter Untergrund
Sicherheitsschuhklasse: FUS Sicherheitsklassen
Schutzschuh Klasse: FUS Schutzklasse
Berufsschuh Klasse: FUS Berufsschuhklasse
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)